These different converters modules enables you to convert your existin documents to the above formats. These are all parts of our Document Converter produt.
Here you can post all the installation and usage issues related to the document converters including our latest DOCX Converter
Post Reply
Posts: 6
Joined: Mon Apr 18 2005


Post by swati » Wed Mar 29 2006

I have a Powerbuilder function called "uf_excel_datawindow" which takes a pb datawindow and saves it as an excel file.

In the function, I use the amyuni control. First I create the Powerprinter object, then I init the printer, then I run a few of the amyuni commands (setresolution, setconfig, etc.) and then I run PDF2EXCEL. After running pdf2excel, the amyuni object is destroyed and the printer disappears.

If I run it once, I get an excel file - NO PROBLEM. The first run is fine.

If I run it again, I get an error calling pdf2excel.
Weird thing is that I don't get an error when I call setresolution or setconfig or whatever.

Any ideas?

Swati Agterberg

Amyuni Team
Posts: 2799
Joined: Wed Sep 11 2002

Post by Joan » Fri Mar 31 2006


Please check that you are calling SetLicenseKey() before PDF2Excel. however this may not resolve your issue.

If it didn't please try using the latest version 2.50g-3 of the Converter.

Hope this helps.

Posts: 6
Joined: Mon Apr 18 2005

Post by swati » Fri Mar 31 2006

The Set LicenseKeyA command is run in my code just before the pdf2excel command.

Why do I have SetLicenseKeyA and you referred only to SetLicenseKey?

I just downloaded and installed 2.50g-4 of the Converter and it didn't help. Is there anything else for me to try?

Post Reply