PDF Report output does not honour transparency settings

If you are a VFP developer and have any questions about using our products from VFP here is the place to post them.
Post Reply
EstatesIT
Posts: 3
Joined: Mon Jul 31 2006

PDF Report output does not honour transparency settings

Post by EstatesIT » Mon Jul 31 2006

We have just upgraded from 2.10 to 2.5 and have found that in Visual FoxPro 9 the PDF output does not support transparency on labels.

Please see that screen shot - you can see that "Class", "Code" and "Description" have white backgrounds but should be transparent and hence have grey backgrounds.
This is with SET REPORTBEHAVIOUR 90, setting this to 80 works OK. But as we are using features on the VFP9 report generator we do not wish to switch to 80 compatibility mode.

Image

Also you will notice that that graphics on buttons appear to be missing on the zoom size and page buttons on the left of the control. This happened in the 2.10 library too and happens Foxpro 8 and 9. We have lived with this so far but thought this may have been resolved in this latest library.

Any suggestions?

Thanks
John R.

Joan
Amyuni Team
Posts: 2799
Joined: Wed Sep 11 2002
Contact:

Post by Joan » Tue Aug 01 2006

Hello,

When using SET REPORTBEHAVIOR = 90 everything is converted to images.

You need to set Postscript simulation on when printing using version 2.50.

Hope this helps.

EstatesIT
Posts: 3
Joined: Mon Jul 31 2006

Post by EstatesIT » Tue Aug 01 2006

I have tried using the setting suggested by adding to our code the lines.

m.loPDFPrinter.SimPostscript = .F.
m.loPDFPrinter.SetDefaultConfig

where m.loPDFPrinter is our PDF Printer ActiveX Object.

However with this setting on, the PDF does not print anything at all. We get a blank PDF document. We are using a standard "REPORT FORM" command to output our reports with the Amyuni printer as the default printer. Without the above setting it produces a correct PDF with the labels non transparent as before.

Also did you have any suggestion for my second issue in my previous post - the graphics on the zoom and page buttons.

Thank you.
John R.

Joan
Amyuni Team
Posts: 2799
Joined: Wed Sep 11 2002
Contact:

Post by Joan » Wed Aug 02 2006

Hello,

You need to set m.loPDFPrinter.SimPostscript = .T.

and using Postscript simulation is in generalt the solution to similar situations.

If you are still facing problems i would suggest that you send a request to our Technical Support Team support@amyuni.com

Concerning the other issue, i will need to check it i am not sure what is the post you are mentioning.

EstatesIT
Posts: 3
Joined: Mon Jul 31 2006

Post by EstatesIT » Wed Aug 02 2006

Sorry it was my mistake, I have been switching between .T. and .F. for testing and put the wrong one in the last post. And for sure the 2.5 driver ouputs a blank PDF when it has this setting below in FoxPro 9.

m.loPDFPrinter.SimPostscript = .T.
m.loPDFPrinter.SetDefaultConfig

As to the second issue. this was from the first post in this thread. Please read the text under the graphics shown.

Thanks
John R.

Joan
Amyuni Team
Posts: 2799
Joined: Wed Sep 11 2002
Contact:

Post by Joan » Fri Aug 04 2006

Hello,

I guess we will not be able to resolve this issue here, i suggest that you send a support request to support@amyuni.com

Concerning your second question, we are aware of this issue i am checking with our developers if this will be changed in the future releases.

Thanks.

Post Reply