4.0.1.2 - Not working on Windows 7 x64 or 2008 x64 WTS

The Amyuni PDF Converter is our Printer Driver that enables you to convert any documents to PDF format. If you have any questions about installing and using the Amyuni PDF Converter please post them here.
Post Reply
lovison@algolsh.it
Posts: 30
Joined: Fri Apr 04 2003

4.0.1.2 - Not working on Windows 7 x64 or 2008 x64 WTS

Post by lovison@algolsh.it » Wed Sep 22 2010

Hi,
I try with simple test program, but I receive error on STARTDOC line :

Code: Select all

       HFONT      font, oldFont;
       HDC         dc;
       DOCINFO      di;
       int         iRetValue;

       dc = CreateDC("WINSPOOL","Algol PDF Test",NULL,NULL);
       if (dc == NULL)
          return;
       memset( &di, 0, sizeof(di) );
       di.cbSize = sizeof( di );
       di.lpszDocName = "Test document";
       di.lpszOutput  = NULL;
       
       iRetValue = EnablePrinter(m_hPDFPrinter,PDFGENERATOR_ACTIVECOMPANY,PDFGENERATOR_ACTIVEKEY);   
       iRetValue = SetFileNameOptions(m_hPDFPrinter,NoPrompt + UseFileName);
       iRetValue = SetDefaultFileName(m_hPDFPrinter,PDFGENERATOR_PDFFILE);
       // EnablePrinter , SetFileNameOptions and SetDefaultFileName are OK with return 1

       iRetValue = StartDoc( dc, &di );
       // ERROR on StartDoc : return -1
SysOp : Windows 7 or Windows 2008 x64 WTS on Intel Core2
Amyuni PDF Converter : 4.0.1.2


Permissions on registry are FullControl for Everyone on
HKEY_CURRENT_CONFIG\Software and HKEY_CURRENT_CONFIG\Software\Algol PDF Test
keys.

If I use Administrator account, the program run ok: which others rights can I check ?!?

two month ago I filled out the form for support, but I received no response.
When you said
you should open a support ticket with our support department.
how do I open this??? I filled form on http://www.amyuni.com/en/support/techsupport.html ,
but I received no response.

I have problems on Win7 / Win2008 x64 ...
I paid for the support and upgrade, but I still have the problem.

:evil:

Theta
Posts: 25
Joined: Wed Jun 25 2003
Location: Australia

Re: 4.0.1.2 - Not working on Windows 7 x64 or 2008 x64 WTS

Post by Theta » Fri Sep 24 2010

does this: http://blogs.stonesteps.ca/showpost.aspx?pid=44 look like your issue?

lovison@algolsh.it
Posts: 30
Joined: Fri Apr 04 2003

Re: 4.0.1.2 - Not working on Windows 7 x64 or 2008 x64 WTS

Post by lovison@algolsh.it » Fri Sep 24 2010

Thank you very much, Theta! :)
You have given me very valuable assistance.
I try to investigate in this direction, thanks!

Fabrizio

Post Reply