Blank box displaying on top of ole control

If you are a Power Builder developer and have any questions about using our products from Power Builder here is the place to post them.
Post Reply
markmazza
Posts: 3
Joined: Tue May 03 2005
Location: Eugene

Blank box displaying on top of ole control

Post by markmazza » Mon Jun 27 2005

I just started using my purchased version of PDF Creator in PB 9. I did not experience this problem with the demo version.

When my window opens (that contains the ole control) it displays with what appears to be a white box that overlays the entire control. If I click just off of it, the underlying control shows the PDF correctly and the white box dissappears. The PDFCReactiveX control is working as expected except for this box appearing?

How can I stop this white box from displaying?

I've registered PDF Suite correctly, I see that the install.ini has all the correct Licensee and license #, and my coding is quite simple..

my_ole_control.object.open(my_datawindow_string_name,"")
my_ole_control.Object.FitToParent = True

Any suggestions?

Mark
mmazza@pacificsource.com

Joan
Amyuni Team
Posts: 2799
Joined: Wed Sep 11 2002
Contact:

Post by Joan » Wed Jun 29 2005

Hello,

I used to use the PDF Creator in Powerbuilder and I never get a white box over the control when running the application.

I would suggest that when loading your datawindow containing the PDF Creator control, you call .SetLicenseKey() and .Refresh() methods before opening a new pdf file using the ole.

Hope this helps.

Post Reply